Outils : Redmine 1.0.0 RC
Le gestionnaire de projet écrit en Ruby on Rails, est disponible au téléchargement. L'utilisez-vous ?

Le , par dourouc05, Responsable Qt
Mise à jour du 29/12/2010 par dourouc05

Citation Envoyé par dourouc05  Voir le message
La veille de Noël, le 23 décembre, est sortie une nouvelle version de Redmine 1.0, la 1.0.5. Qu'apportait donc Jean-Philippe Lang dans sa hotte ? Peu de choses : onze bogues corrigés, l'incompatibilité avec i18n 0.5.0 est corrigée (la version 0.4.2 est maintenant requise), en plus de trois failles de sécurité corrigées.

Notons également que Redmine 1.1, initialement prévu pour le 31 de ce mois, a été reporté de neuf jours, soit le 9 janvier de la nouvelle année. 95 % du total sont déjà achevés, la nouvelle version arrivera-t-elle comme prévu ?

En avril, nous devrions avoir droit à Redmine 1.2, qui devrait changer un peu les prérequis car elle passera à Rails 2.3.10 - à quand Rails 3 ?

Source : http://www.redmine.org/news/49

Voir aussi

La rubrique Ruby & Ruby on Rails de Developpez.com
L'hébergement des projets Developpez.com

Mise à jour du 28/11/2010 par dourouc05

Citation Envoyé par dourouc05  Voir le message
Redmine 1.0.4 vient de sortir, il y a à peine quelques heures. Quinze bogues ont été corrigés, sept traductions ont été mises à jour ; selon la formule désormais consacrée... eh non, cette fois, c'est Jean-Philippe Lang, initiateur du projet, qui a fait l'annonce de cette version, nous n'aurons donc pas de « so this this should be a very stable release. Upgrading is recommended for all 0.9.x and 1.0.0 users. ». Il était assez absent ces derniers mois, a fait surface lors de la sortie précédente de Redmine et semble maintenant vouloir se remettre dans le projet.

Pour le meilleur comme pour le pire ?

Source : http://www.redmine.org/news/47 et http://www.redmine.org/news/46

Voir aussi

La rubrique Ruby & Ruby on Rails de Developpez.com
L'hébergement des projets Developpez.com

Mise à jour du 09/11/2010 par dourouc05

Citation Envoyé par dourouc05  Voir le message
Redmine 1.0.3 est sorti il y a peu, début novembre. Comme les versions précédentes, il ne s'agit ici que d'une correction de bogues... 35, comme compte si bien Eric Davis, Release Manager de Redmine.

Cependant, quelque chose d'un peu étonnant était à remarquer lors de la sortie de cette version... Étant donné que je suis l'actualité de Redmine d'assez loin, je n'ai pas regardé l'avancement des tâches tous les jours... mais je fus assez étonné de remarquer que, quelques jours avant la sortie de cette version, aucune tâche n'était marquée résolue ! Faut-il y voir un signe ? Les développeurs s'orienteraient-ils plus vers Redmine 1.1.0, version toujours prévue pour la fin décembre 2010 ?

Petite note en passant : juste après la sortie de Redmine 1.0.3, un nouveau répertoire de plug-ins a été mis en place sur le site, remplaçant la vieillissante liste de plug-ins. Il était bien temps, Redmine disposant de plus en plus de plug-ins à afficher... Comment remarquer les nouveautés ? Ce problème est maintenant résolu !

Remarquez que les scripts Redmine.pm et reposman.rb ont été mis à jour ; si vous les utilisez pour une intégration avancée avec Subversion (qui permet la création de repositories depuis Redmine, notamment), vérifiez bien que vous mettez tout ce qu'il faut bien à jour.

Sources : http://www.redmine.org/news/45 et http://www.redmine.org/news/46

Voir aussi

La rubrique Ruby & Ruby on Rails de Developpez.com
L'hébergement des projets Developpez.com

Redmine 1.0.1 vient de sortir, il s'agit de la version finale de Redmine 1.0. Sortie avec quelques jours de retard, il s'agit de la version stable et finalisée de Redmine 1.0.0, qualifiée alors de Release Candidate (RC).

Au menu de cette version, la correction d'une série de bogues (57 précisément) : cette version est donc "très stable", pour reprendre les mots d'Éric Davis, Release Manager de Redmine.

Source : http://www.redmine.org/news/43

Voir aussi

La rubrique Ruby & Ruby on Rails de Developpez.com
L'hébergement des projets Developpez.com

Et vous ?

Avez-vous déjà essayé Redmine 1.0.0 ? Quelle en fut votre expérience ? Comptez-vous migrer vers cette version 1.0.1 dès que possible, comme recommandé ?

Mise à jour du 25/08/2010 par dourouc05.

La version 1.0.0 de Redmine est sortie il y a peu. Elle est toujours considérée comme RC (Release Candidate), la version finale devrait sortir vers la fin août (le 20, précisément), même si cette version est « prête pour des tests en production ».

Redmine est, à l'instar de Trac, un gestionnaire de projet flexible prévu pour le Web écrit avec le framework bien connu Ruby on Rails. Il est souvent décrit comme plus facile à installer et à utiliser que Trac tout en fournissant les fonctionnalités attendues mais non trouvées dans Trac. Il est prévu pour être utilisé sur tous les systèmes d'exploitations sur lesquels Ruby 1.8 est porté ainsi qu'avec toute une série de bases de données (MySQL, PostgreSQL et SQLite). Il est aussi compatible avec toute une série de SCM : Subversion, évidemment, CVS, Darcs, Git, Mercurial, Bazaar, vous pouvez même coder vous-même un plug-in pour en supporter un autre). Il faut aussi signaler que cette application est celle utilisée sur l'hébergement des projets Developpez.com.

Au programme de cette version majeure, le support des sous-tâches, principalement. Aussi, les textes formatés sont maintenant mis en cache. Finalement, l'application dispose désormais d'une API REST.

Source : http://redmineblog.com/articles/redmine-1.0.0-released

Voir aussi

La rubrique Ruby & Ruby on Rails de Developpez.com
L'hébergement des projets Developpez.com

Et vous ?

Utilisez-vous Redmine pour vos projets ? Quelle expérience en retirez-vous ?
Utilisez-vous un autre gestionnaire de projets que Redmine ? Envisagez-vous une migration vers Redmine ?



Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de dourouc05 dourouc05 - Responsable Qt http://www.developpez.com
le 27/09/2010 à 14:11
Redmine 1.0.2 vient de sortir, il s'agit de la première série de correction de bogues depuis la sortie de la version finale, la 1.0.1.

Au menu de cette version, la correction d'une série de bogues (53 précisément) : cette version est donc "très stable", pour reprendre les mots d'Éric Davis, Release Manager de Redmine, qui n'ont pas changé depuis Redmine 1.0.1.

Notez qu'il n'y a pas encore de correction prévue pour Redmine 1.0.3, alors que certaines étaient prévues depuis un an et sont finalement arrivées pour Redmine 1.0.2.

Source : http://www.redmine.org/news/44

Voir aussi

La rubrique Ruby & Ruby on Rails de Developpez.com
L'hébergement des projets Developpez.com

Et vous ?

Êtes-vous toujours sur Redmine 0.9.x ? Pourquoi restez-vous sur cette vieille version ?
Avatar de trident_job trident_job - Membre averti http://www.developpez.com
le 27/09/2010 à 21:08
moi je trouvais la v0.9.x deja très stable, alors là ... ça semble impec !

La migration de la v0.9.x à la V1.01 n'avait pas posée de problème, je vais franchir le pas cette semaine, ce sera fait

Ca fait du bien de voir des produits "finis" et stable qui respecte la roadmap (le contenu j'entends).
Ca change des jeux video (paf le troll).
Avatar de Bluespear Bluespear - Membre régulier http://www.developpez.com
le 27/09/2010 à 21:30
Erf, je viens d'effectuer une migration 0.8.* à 1.0.1... et la 1.0.2 sort
A part 2 plugins incompatibles (Graph je crois et un autre qui est maintenant intégré à Redmine, pas trop d'incompatibilité). Avoir les versions requises de Ruby et autres libs sur CentOS et la config apache avec fastcgi c'est par contre une autre histoire

J'ai beaucoup utilisé Assembla et Trac, je dois dire que Redmine c'est vraiment le must en comparaison.
Avatar de dourouc05 dourouc05 - Responsable Qt http://www.developpez.com
le 09/11/2010 à 21:56
Redmine 1.0.3 est sorti il y a peu, début novembre. Comme les versions précédentes, il ne s'agit ici que d'une correction de bogues... 35, comme compte si bien Eric Davis, Release Manager de Redmine.

Cependant, quelque chose d'un peu étonnant était à remarquer lors de la sortie de cette version... Étant donné que je suis l'actualité de Redmine d'assez loin, je n'ai pas regardé l'avancement des tâches tous les jours... mais je fus assez étonné de remarquer que, quelques jours avant la sortie de cette version, aucune tâche n'était marquée résolue ! Faut-il y voir un signe ? Les développeurs s'orienteraient-ils plus vers Redmine 1.1.0, version toujours prévue pour la fin décembre 2010 ?

Petite note en passant : juste après la sortie de Redmine 1.0.3, un nouveau répertoire de plug-ins a été mis en place sur le site, remplaçant la vieillissante liste de plug-ins. Il était bien temps, Redmine disposant de plus en plus de plug-ins à afficher... Comment remarquer les nouveautés ? Ce problème est maintenant résolu !

Remarquez que les scripts Redmine.pm et reposman.rb ont été mis à jour ; si vous les utilisez pour une intégration avancée avec Subversion (qui permet la création de repositories depuis Redmine, notamment), vérifiez bien que vous mettez tout ce qu'il faut bien à jour.

Sources : http://www.redmine.org/news/45 et http://www.redmine.org/news/46

Voir aussi

La rubrique Ruby & Ruby on Rails de Developpez.com
L'hébergement des projets Developpez.com
Avatar de trident_job trident_job - Membre averti http://www.developpez.com
le 09/11/2010 à 22:15
Merci dourouc05 pour ces infos.
La liste des plugins est bien fournies ... c'est bon signe
Avatar de Firwen Firwen - Membre expérimenté http://www.developpez.com
le 10/11/2010 à 14:22
Toujours aussi bon

Seul problème inhérant à Rubis et non à redmine, ça supporte assez mal la charge
Avatar de Klaim Klaim - Membre expert http://www.developpez.com
le 10/11/2010 à 15:15
Même avec la derniere implémentation de ruby?
Avatar de dourouc05 dourouc05 - Responsable Qt http://www.developpez.com
le 10/11/2010 à 21:58
Redmine n'est compatible qu'avec Ruby 1.8.{6,7}, ce qui limite fortement les possibilités. Ce n'est pourtant pas Rails qui est limitant à ce niveau, apparemment... Une idée si Redmine 1.1.x va supporter Ruby 1.9 ? Ça risque pourtant d'être utile, niveau perfs, apparemment, pour des gros utilisateurs...
Avatar de dourouc05 dourouc05 - Responsable Qt http://www.developpez.com
le 28/11/2010 à 21:47
Redmine 1.0.4 vient de sortir, il y a à peine quelques heures. Quinze bogues ont été corrigés, sept traductions ont été mises à jour ; selon la formule désormais consacrée... eh non, cette fois, c'est Jean-Philippe Lang, initiateur du projet, qui a fait l'annonce de cette version, nous n'aurons donc pas de « so this this should be a very stable release. Upgrading is recommended for all 0.9.x and 1.0.0 users. ». Il était assez absent ces derniers mois, a fait surface lors de la sortie précédente de Redmine et semble maintenant vouloir se remettre dans le projet.

Pour le meilleur comme pour le pire ?

Source : http://www.redmine.org/news/47 et http://www.redmine.org/news/46

Voir aussi

La rubrique Ruby & Ruby on Rails de Developpez.com
L'hébergement des projets Developpez.com
Avatar de trident_job trident_job - Membre averti http://www.developpez.com
le 28/11/2010 à 21:56
j'aime les developpements aussi réactifs !
Et la v1.1.0 arrive bienôt ... ~70% de fini !
Avatar de dourouc05 dourouc05 - Responsable Qt http://www.developpez.com
le 29/12/2010 à 20:35
La veille de Noël, le 23 décembre, est sortie une nouvelle version de Redmine 1.0, la 1.0.5. Qu'apportait donc Jean-Philippe Lang dans sa hotte ? Peu de choses : onze bogues corrigés, l'incompatibilité avec i18n 0.5.0 est corrigée (la version 0.4.2 est maintenant requise), en plus de trois failles de sécurité corrigées.

Notons également que Redmine 1.1, initialement prévu pour le 31 de ce mois, a été reporté de neuf jours, soit le 9 janvier de la nouvelle année. 95 % du total sont déjà achevés, la nouvelle version arrivera-t-elle comme prévu ?

En avril, nous devrions avoir droit à Redmine 1.2, qui devrait changer un peu les prérequis car elle passera à Rails 2.3.10 - à quand Rails 3 ?

Source : http://www.redmine.org/news/49

Voir aussi

La rubrique Ruby & Ruby on Rails de Developpez.com
L'hébergement des projets Developpez.com
Offres d'emploi IT
TECHNICIEN SUPPORT DE PROXIMITE
AURA - Ile de France - paris
Expert bo h/f
Global Technologies - Ile de France - Ile de France
(H/F) CONSULTANT TECHNICO FONCTIONNEL SIRH CHEZ EDITEUR
STUDIO RH - Nord Pas-de-Calais - Lille (59000)

Voir plus d'offres Voir la carte des offres IT
Contacter le responsable de la rubrique Ruby & Rails